股票配资公司_在线配资网站_网上配资平台-武汉配资网
您的位置:首页 >配资炒股 >

MACD四种形态的选股公式

时间:2020-03-26 21:39:17 | 来源:股票配资网
MACD四种形态的选股公式

4种利用MACD选股公式分别是:二次金叉,二次翻红,DIF下破0轴及0轴附近金叉。一起来看看

(1)二次金叉:

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

(2)二次翻红:

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

FH1:=REF(MACD,1)

FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;

FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);

FH4:=FH1 AND FH2 AND ABS((DIFF-DEA)/C)<0.018;

FH5:=FH1 AND FH2 AND MACD<0.10;

FH3 OR FH4 OR FH5;

(3)DIF下破0轴:

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

均线向上:=EMA(C,144)>=REF(EMA(C,144),1) AND EMA(C,233)>=REF(EMA(C,233),1);

破0轴:均线向上 AND REF(DIFF,1)>0 AND DIFF<0;

(4)0轴附近金叉(特别是0轴之上):

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9),LINETHICK1;

CROSS(DIF,DEA) AND DEA>-0.05;

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如有侵权行为,请第一时间联系我们修改或删除,多谢。